I'll probably end up asking Amazon for a refund on:

XQuery: Search Across a Variety of XML Data

Product details

Paperback: 762 pages
Publisher: O'Reilly Media; 2 edition (Jan. 7 2016)
Language: English
ISBN-10: 9781491915103
ISBN-13: 978-1491915103
ASIN: 1491915102

due to a persistent error:


An error occurred. If you purchased this item from Amazon, delete the item and download it from the Cloud.

Short of setting the Kindle to factory defaults I'm at a loss, but can speculate that perhaps the code in the book might be causing some problems.

see also:

Paperwhite error on open book, how do I get the error log?


6 Answers 6


Most likely you downloaded a partial file or it was corrupted somehow. Just delete it from your device and try again. (Alternatively, remove it by going to Manage Your Content and Devices.

Don't delete the ebook from all devices, just the one device you are working on.

Failing that, you can also contact Oreilly or even the author and include a receipt. Oreilly is a great publisher, and they would probably be able to send you via email the file to you if you asked nicely.

Quality control on Oreilly ebooks is pretty high. I doubt there's a formatting issue. The file is 5mb, not too big. But it might be worthwhile trying to view it on a Kindle app on a tablet or on Kindle for PC Desktop.

Occasionally I have an issue downloading certain ebooks. Often it's a matter of just deleting the first version you downloading and retrying. Sometimes it gets stuck, but I'm generally able to download everything. Hope this helps!

  • I'm getting this same error, and I've deleted and re-downloaded the book thrice now. I don't think this is a universal fix. Commented Jan 13, 2020 at 5:38

I had the same problem. I contacted Amazon to solve it. The problem was a software update. Apparently, my kindle did not update vis wifi, so I updated it via manually via their website.

  • I was facing the same issue. Updating the firmware to v5.13.3 solved it for me. Commented Oct 30, 2020 at 17:31

I just tried hard reset in my kindle paperwhite and it solved the problem. just hold the power button for 20 seconds and let it restart.


I have this issue as well

Fix that works for me:

  1. Delete book
  2. Restart kindle
  3. Download book
  4. Read book

I read somewhere that it could be an issue relating to low battery, but this morning it happened with 54% power.


I had the same issue and I called the customer service. They said before I had bought the book and since I also had a kindle unlimited account, the book was just being borrowed. But my subscription ended and I could not borrow it anymore. The issue got fixed once I hard restarted the kindle as per the instructions from the customer service representative.


I had the same issue and:

  1. Program Calibre and MOBI to AZW3
  2. Download book AZW3 and is OK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.