1

I'm trying to convert an azw book to epub. Calibre completes the conversion with no problem, but the font has changed (to something ugly). I know I can use the look and feel settings to fix this, but I'm curious why this is happening. When I look inside the resulting epub file, I find a number of .ttf files with names like 00001.ttf in the fonts folder, but when I try to open one, I get a message "invalid font file". The CSS refers to the font E B Garamond, which I don't have (though I do have Garamond).

I can use the look and feel settings to substitute the Garamond font, but why are invalid font files be written? Why does the CSS name a font not present in the file?

0

You are best served to ask this in the Calibre Support forum on MobileRead.com. Calibre author Kovid Goyal is an active participant. See https://www.mobileread.com/forums/forumdisplay.php?f=166

MobileRead is a privately funded site with free signup. It's the single best site I am aware of for all things eBook.

(Disclaimer: I am on staff and a moderator, thus biased. :-) )

  • Thanks, I'll give it a try since nothing is turning up here – Llaves Apr 13 at 2:49
0

The original fonts are not embedded. If you don't have the specified font installed (E B Garamond) then your device will pick a default or replacement font to display.

why are invalid font files be written?

That's a question for Kovid, but AZW to epub doesn't seem like a common-use scenario for Calibre. Where'd you get the AZW file?

Why does the CSS name a font not present in the file?

It's a common mistake in ebook design. People want to style their books with unique fonts, but you have to own the copyright to embed the font. So at some point - probably when it was converted to AZW by Amazon - the embedded fonts got stripped out.

In terms of what to do, I would use Calibre to edit the epub, delete all the .ttf files, and just do a find and replace-all to change or delete the font-face in the stylesheet.

  • I unpacked the AZW and it appears that the font files inside are invalid TTFs, yet this book renders correctly in the Windows Kindle app on the same machine that doesn't have E B Garamond. Is this font somehow incorporated into the Kindle app itself? Or perhaps Amazon uses some non-standard format for the TTF to prevent it from being copied? – Llaves Apr 14 at 5:06
  • Well, back to your original question, what do you mean by "tried to open" the ttf file, and what program told you it was invalid? Maybe it's not invalid at all, it just got renamed. Kindle does have native fonts but I don't think Garamond is one of them. Another possibility is that the Kindle is ignoring the embedded font completely and is displaying something else. In other words, are you sure you're looking at Garamond when you open it in Kindle? – b_q Apr 15 at 13:15
  • WIndows will preview a font if you double click a .ttf file. That's what I tried to do with the fonts embedded in the .azw and epub files. As whether the Kindle app is using Garamond - I'm no font expert, but it does look a like Garamond to me. – Llaves Apr 16 at 14:07
  • Gotcha. So, possibly the ttf file just doesn't have the right metadata for Windows to be able to preview it. Is this for personal use or for publishing? I can help if you need. – b_q Apr 17 at 15:37
  • At this point it's more just idle curiosity. I converted the book using the "look and feel" options and got what I wanted. I was just curious why this was occurring. – Llaves Apr 18 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.