My KT stopped working all of a sudden and will no longer turn on. I have tried the holding down the power button trick numerous times and charged it for over 24 hours but there is still no response. I also tried using Kubrick but when I boot into it, the wizard doesn't start automatically and I can't figure out how to run it manually.

Sorry about the quality of screenshot but this is where kubrick stops.


Anybody have experience with this situation?

  • Do you get a charge indicator light when charging? – James Jenkins Jan 29 '14 at 12:05
  • @JamesJenkins Yes but it seems to be a bit random as to which colour the light is. It's mostly orange but has gone green and back to orange and sometimes no light, all on the same charge... – doovers Jan 29 '14 at 13:01
  • Can you specify how exactly the wizard does not start? Are there any error messages? Do you see something like kubrick login: or root@kubrick:~#? – Tim Jan 30 '14 at 11:34
  • Also a very simple workaround would be to try the live cd on another pc. – Tim Jan 30 '14 at 11:48
  • 1
    @doovers This basically means that the livecd is not booted (its bootloader does not find something). I suggest we should try to troubleshoot in chat instead of discussing in the comments. – Tim Jan 30 '14 at 12:20

It may be that your battery has burst. That would be the most likely cause of an abrupt breakdown. If the device is no longer under warranty, I'd suggest opening it up (check for videos on YouTube) and having a look. Replacement batteries are easily obtainable and, if you can operate a screwdriver, putting one in is within any user's capability.

  • 1
    Thank you for the suggestion. One question though, if the battery was goosed, would the kindle show up intermittently as a USB device when plugged in to my laptop? – doovers Jan 30 '14 at 21:35
  • I don't know. But I speculate there is an intermediate state between "OK" and "complete failure" that might permit that. – Roger_S Feb 3 '14 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.