2

I tried uploading several books from Project Gutenberg and I'm getting errors on a few stating in red that "This file cannot be processed".

I click on the learn more link but it doesn't really connect me to anything debug worthy.

error uploading books to GPB Anybody know how to get information about what exactly went awry?

2

Initial things to try: Have you used an epub validator to confirm that it is a valid epub? Is the file encrypted in some way? (Can you view it in a browser or readium or Adobe Digital Editions)? Was the upload interrupted? I would remove and try again. In my experience though, GPB has been pretty reliable for valid epubs.

example of invalid eBook result.

  • Nice tool indeed! Looks like the poor book is invalid. – jxramos Aug 10 '17 at 18:03
3

So I solved this issue by converting epub file to mobi format (mobi is the format kindle uses) and then converting back to epub. After doing this, google books didn't have issues processing it. There are multiple online converters you can use.

  • I did this for a book failing to be processed by Google Play Books and I now can read it on my phone app. – Francisco Jun 8 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.