9

I am the book author and I have access to KDP and can preview my internal texts from there. I have checked and double checked the internal version did indeed update to fix typo and a program (for arduino) fixed where it had two LARGE errors. The program would crash and not work. So this is definitely a major edit in my point of view.

Now I am completely lost here. I tried to push the correct version live to my book. It looks like it passed the review progress. Not to mention preview from KDP website shows the correct version. I only have one copy of that book listed in KDP.

For some strange reasons two of my books on my dad's android kindle copy still shows the old outdated version. I tried to follow the link to "manage content and devices on amazon website" for my dad's account. It doesn't show anything about updating my old book? All it does is give me option to turn on/off automatic book updating. I tried deleting and re-download that didn't do anything.

The link article below didn't help with my issue.

https://www.amazon.com/gp/help/customer/display.html?nodeId=201252670

What I would like to know is there an easy way to "force" all digital book to update to the newer revision edition without contacting support? I am asking mainly because it seem that the normal way of doing it doesn't even fix the outdated edition.

  • No I am asking is there a way to force through the revision of a digital book on createspace without contacting support? – Vyndicu Jan 2 '17 at 14:15
2

To answer your last question, no it should not be necessary to contact support to receive an updated version of an ebook. If a kindle account has chosen to enable automatic updates, these updates should just show up.

Whether the Kindle device does this reliably is a separate question of course. Let's try to troubleshoot the obvious things. Let me say that I use KDP a lot and have never had problems like you have suggested.

Has your dad's account turned off automatic updating? Possibly the problem is one with your dad's device; can you verify that it has Internet and can download other titles? Most devices have a SYNC button which can force a sync.

You should also try to test this for other accounts/devices. You can do this by making an insignificant update on the title page. (maybe add an extra word or letter). Update that version and then you can download a sample of the ebook on another device and see what happens.

The key thing is to establish whether it is happening to all accounts and all devices, or only your dad's account or only to one device of your dad's. That would seem relatively easy to do.

You should also check to see if there are more than one versions of the same ebook on the same device. This has happened to me before. I will upload one version for testing, and then have alongside it a version available for sale. It may appear that the ebook has not been updated when all I have been doing is viewing an older version of a file which I uploaded earlier.

One other thing. This may not apply to you, but often while testing ebooks I upload ebooks to a specific device using the Manage Personal Documents feature. If you are uploading a no DRM ebook (as opposed to downloading an ebook you have paid for), the device will process the ebook somewhat differently. Also, it can be easy to accidentally specifically a wrong device if the account had multiple devices associated with it. So for uploading Personal Documents (in this case ebooks), you should doublecheck whether you have chosen to send the updated file to the right device.

(Hey, please let SE know what happens. I'm in the middle of updating 3 ebooks right now, and remain curious about where things messed up).

  • The thing is update for my dad's kindle book IS NOT showing up even with automatic update enabled. I tried turn on/off and delete and re-download. Nothing! The front page still show the outdated version. Fairly easy typo to spot. Forward instead of Foreword. My dad version is the brought one and only one version available on amazon. My KDP account book previewer shows the proper version. – Vyndicu Jan 2 '17 at 22:29
  • verify that another device/app in your dad's name shows the latest version. That could simply mean downloading the desktop client on Windows. My theory is that the problem is specific to one device only. – idiotprogrammer Jan 4 '17 at 2:21
  • I already tried logging on the dad's account on website. It shows nothing. Furthermore did you read the third paragraph? I clearly stated I tried looking for something on that same website. – Vyndicu Jan 4 '17 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.