2

I had made an ebook with Calibre and copied it to my Kindle through the USB cable. Then I tried deleting the book from the Kindle. The cover changed to the default cover, but it did not disappear. When I tried opening it, it said "Item not available. The item you were reading has been removed..."

I tried rebooting the Kindle, but the deleted ebook is still there.

0

Try deregistering and reregistering your Kindle:

  • Have the Kindle online through Wifi.
  • Press Menu (three lines stacked).
  • Press Settings.
  • Press Registration.
  • Press Deregister Device and confirm it.
  • Wait a few seconds for it to take effect.

Repeat the above steps, but pick to register instead of deregister.

My collections had to be added back to the Device from the Cloud, and I had to set the parental control password again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.