6

Reading Chinese on my Paperwhite I need to look up lots of characters. Often the Kindle offers me the Wikipedia lookup first and I have to swipe over to the translation or dictionary. Wikipedia is literally never the one I want. Is there a way to stop the Kindle from going to it, or at least stop the Kindle from offering it as the first choice?

People not familiar with Chinese may not see why this is such a problem, so I'll explain. Many (maybe most) words in modern Chinese are two characters long. But sentences are written with no breaks between words. So you often look up two-character combinations -- and you will often pick two characters that some given dictionary does not recognize as one word. In that case Bing translate will almost always get it right for you. Wikipedia will almost never help at all. Wikipedia is great, but is not designed to help people read novels!

Combined with other infelicities in the way Kindle handles Chinese characters, the frequent pointless detours through Wikipedia waste a lot of time.

1

Enable airplane mode. No Wifi = no Wikipedia lookup.

  • No. Then the Kindle still goes to Wikipedia first. Only it gives an error message saying to turn off airplane mode. It also seems to block access to the Chinese-English dictionary. – Colin McLarty Dec 1 '15 at 18:54
  • I'll only go to the Wikipedia first, if the default dictionary doesn't contain the word. Did you set the default dictionary to the Modern Chinese English dictionary or the monolingual Chinese dictionary? (Settings > Device Options > Language and Dictionaries > Dictionaries > Chinese) – Nemo XXX Dec 1 '15 at 20:35
  • Yet it goes to Wikipedia when Wikipedia does not have the word, even when translation does have it. I use both the Modern Chinese English dictionary and the monolingual Chinese as defaults at different times. The problem remains that Kindle goes to Wikipedia first when I never want it to go there at all. Kindle look up of Chinese characters is balky in several ways worse than this one, but it seems this problem should be easily fixable by setting user preferences. – Colin McLarty Dec 1 '15 at 21:07
0

I just found out the perfect method:

Step 1: Choose your secondary dictionary (for me, it's Oxford Dictionary) in the settings of the device as the main dictionary.

Step 2: When you start a new book, click on a word and choose your favorite (in my case: hungarian) dictionary instead of secondary.

So, kindle will know that if your mother language dictionary can't find a word, it has to switch to the 2nd dictionary instead of Wikipedia.

-1

No, you cannot.

Airplane mode just makes Kindle go to the Wikipedia panel to tell you to turn off airplane mode. As Nemo XXX says, this happens when the the word is not in the dictionary.

If a word is not even in the dictionary, Wikipedia is unlikely to have an article on it! But for now Kindle insists on letting the Wikipedia panel give you this bad news. Only then will Kindle let you go to translate for the answer you actually wanted.

  • Airplane mode apparently disables all dictionaries except the American Heritage. That's incorrect. My Kindle is almost always in Airplane mode and I can access all dictionaries regardless of the language. Have you tried the following: 1. Change the default Chinese dictionary? 2: Change the UI to Chinese? – Nemo XXX Dec 4 '15 at 15:21
  • Also check the book's language metadata with Java Mobi Metadata Editor (If the language metadata entry of a Chinese book is defined as English, it'll never cause the Chinese dictionary to open.) – Nemo XXX Dec 4 '15 at 15:27
  • @Nemo The metadata is working since my Kindle very often succeeds at looking up the Chinese words. There is a problem changing the default dictionary, since my Kindle reports that is already on the Chinese-English dictionary when this happens (or the monolingual Chinese dictionary, sometimes, depending on which I set). Nonetheless I have tried changing to the other Chinese dictionary which the Kindle duly reports I have done, yet it will not access that dictionary either when on airplane mode. – Colin McLarty Dec 4 '15 at 15:36
  • @Nemo Do you use Chinese dictionaries? Or which ones do you use? – Colin McLarty Dec 4 '15 at 15:39
  • The metadata is working since my Kindle very often succeeds at looking up the Chinese words. Humor me, and double-check it with the Metadata editor. Also, it couldn't hurt to temporarily change the UI language to Chinese. If none of this makes a difference, there might be a Chinese-only firmware bug, because I can use non-English dictionaries in three different languages and only get the Wikipedia dialog box, if the word isn't in the default dictionary. Nemo Do you use Chinese dictionaries? No. But I use a home-made Arabic dictionary without any problems in airplane mode. – Nemo XXX Dec 4 '15 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.