I used to be able to remove books from my Sony PRS-T1 reader using Calibre (either one by one or en masse). I am running a fully updated version of Windows 7, and I have the latest version of Calibre (1.20), and tried today to remove some books (both one at a time, and multiples at a time), and I keep getting the following error when I try:

calibre, version 1.19.0 ERROR: Error: Error communicating with device

[Error 5] Access is denied: u'M:\Sony_Reader\media\books\The Zombie Survival Guide_ Complete Prot - Max Brooks.epub'

Traceback (most recent call last): File "site-packages\calibre\gui2\device.py", line 85, in run File "site-packages\calibre\gui2\device.py", line 596, in _delete_books
File "site-packages\calibre\devices\usbms\driver.py", line 345, in delete_books WindowsError: [Error 5] Access is denied: u'M:\Sony_Reader\media\books\The Zombie Survival Guide_ Complete Prot - Max Brooks.epub'

While the filename listed will change (depending on the book I am trying to delete), the message is the same - I can't delete ebooks from my device.

Is there anything I can do to solve this error?

  • Can you delete the file manually, i.e. in the explorer without using Calibre?
    – his
    Jan 14, 2014 at 13:13
  • I can delete it on the device manually but I have not tried using the file Explorer to do so.
    – user151
    Jan 14, 2014 at 13:31
  • See suggestion in chat Jan 14, 2014 at 15:47
  • 1
    I think you need to provide more relevant information: What is your version of Calibre. Guessing have Windows (from path in the error message, which version?
    – Regina T.
    Jan 16, 2014 at 9:12
  • @ReginaT. I added those details in :)
    – user151
    Jan 17, 2014 at 5:47

2 Answers 2


It might be that the TRS-1 plugin for Calibre is broken, or that Calibre deletion is broken in the version you have. I would try to delete files outside of Calibre using the steps here, and if that works blame things on Calibre, file a bug-report and wait for the next version.


This is a security feature in windows that is intended to prevent malicious programs from removing content from your devices with out your permission. Depending on how the program is implemented you may be able to delete files if you start Calibre with administrator privileges. Simply right click the shortcut and choose "Run as administrator."

  • I am not convinced that is the case, as I used to be able to do it with no issues, and nothing has changed about my Windows install since then.
    – user151
    Jan 16, 2014 at 5:37
  • @AshleyNunn - You have not installed the latest security patches? Mine broke about 6 weeks ago after one. If I run in admin mode then it works. I do not know about calibre but I noticed it with an app for managing my mobile phone.
    – Chad
    Jan 16, 2014 at 15:04
  • @AshleyNunn: I have seen similar issues where a windows update was applied and it affected a program or two that used to run without admin privs, but then required me to run it as admin.
    – Jason Down
    Jan 16, 2014 at 17:40
  • I tried running it as an administrator, and the same thing happened. :(
    – user151
    Jan 17, 2014 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.