9

I have been primarily reading eBooks using Play Books on my Android tablet, however today I tried out the Amazon Kindle app and tried to download some of their free eBooks to test it out and compare the two applications.

However, whenever I try and get an eBook through the Kindle app I see "Available for download now" in the main list but when I tap on a title I get the message "This title is not currently available for purchase" as follows;

enter image description here

This currently seems to be affecting everything that I tap on in the Kindle app. Have I done something wrong? How can I "purchase" a free eBook through the Kindle app on Android?

  • 6
    Wouldn't Amazon tech support be a more appropriate venue for this question? – Donald.McLean Jan 3 '14 at 12:24
  • 1
    @Donald.McLean - Is there a reason that we could not help the OP find the answer here? We should not be pointing users to other locations to ask questions about ebooks unless the question they are asking is out of scope. – Chad Jan 16 '14 at 16:50
6

It looks like this is an Amazon based issue.

This book is currently unavailable because there is an issue with its description, content, or formatting.

We are working with the publisher to fix the issue. As always, we value customer feedback.

Note that is book is avaiable at Wikisource & PG

Amazon Screen shot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.