8

Sometimes a book doesn't really have an explicit "author", but is rather authored by some group. So for example maybe there's a book about Croatian politics that's by "The Croatian Studies Institute". In Calibre, I'll put the group's name in the author field.

But if instead of Croatian politics, maybe it's about the politics of Bosnia and Herzegovina, and it's by "The Bosnian and Herzegovinian Studies Institute". If I enter this in as the author, Calibre will convert it to "The Bosnian & Herzegovinian Studies Institute", and consider it to have two distinct authors, "The Bosnian" and "Herzegovinian Studies Institute".

Is there a way to tell Calibre, no, really, the one single author is named "The Bosnian and Herzegovinian Studies Institute"?

  • I would use "The Bosnian-Herzegovinian Studies Institute". – Sekhemty Aug 17 '14 at 18:14
  • 1
    What version of Calibre are you using? I don't get this behaviour on version 1.48. – evilsoup Aug 20 '14 at 14:51
  • It's happening for me now on 2.0.0. I don't remember what version I was using at the time of the question, but it was either 2.0.0 or a very recent 1.*. – Bob Vesterman Aug 27 '14 at 22:54
4

I use Calibre 2.20 and I find, that if you forego using the "Edit metadata" button and just click on the Author field in the main window and edit the name there, you get to keep the "and".

Calibre Main Window

If you click on "Edit metadata" afterwards you will notice that the "Author sort" field has a red marking, however, it should work fine regardless.

When you do sort, it will sort using the word "The" as far as I can see. In other words it does not think any of the other words is the last name.

The folder will also be named correctly as you can see here in the screen shot.

The folder in the Finder window

  • This doesn't seem to work anymore. When I click the author area and change the "&" to "and" it goes back to "&" when I press enter. They must have changed this functionality. I'm on Calibre 3.39.1. – jimmyplaysdrums Feb 7 at 19:37
5

You can change default behaviour in Preferences/Tweaks:
# Splitting multiple author names

The default setting is:
authors_split_regex = ',?\s+(and|with)\s+'

When you clear that, Calibre won't split author names.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.