Transferring ebooks in mobi file to my kindle used to be hassle free. I just drag it to the "documents" folder and voilà! They're there.

What happened yesterday was different. I tried to move mobi ebooks to my kindle. The books were transferred fine, I can see them on my kindle drive on the computer. The problem was when I opened my Kindle to arrange the books I transferred, they weren't there. I tried reconnecting my kindle to the computer and the books are still there. I don't know what's wrong.

  • I don't have a kindle, so I am not sure what causes the software on it to rescan the drive. Normally, on other ebook readers, this is done once based on disconnecting the USB, and the software tells you it is scanning. Try to connect using USB and disconnect. If that doesn't work a restart of the machine might help. As for the cause, my guesses are a software glitch, or a reset time on the device.
    – Anthon
    May 20, 2014 at 13:50
  • Are you sure the .mobi documents are fine? Maybe they're corrupted, or perhaps were corrupted once transferred. How much free space remains in your device?
    – Nicolás
    May 20, 2014 at 14:42
  • What kind of Kindle are we talking about? The Fire interface is different than the Kindle DX or Paperwhite interface.
    – Tom
    May 20, 2014 at 17:42
  • You can use SENDTOKINDLE app, can't you?
    – user2890
    Nov 16, 2014 at 23:31
  • Try and use Calibre to transfer them and see if that doesn't work.
    – user293129
    Feb 3, 2015 at 2:56

8 Answers 8


File size can be an issue. I've found that if the book's file size is greater than 50MB, the file will transfer to the documents folder on disk, but not appear on the kindle. In my case, I used Calibre to convert mobi to azw3, which reduced the file size, and the book then appeared on my kindle.

  • A 50 MB book? That's larger than many games!
    – Jax
    Jun 9, 2016 at 22:20

Here are my personal suggestions, I'm not sure they work well.

  1. Restart you Kindle, then touch home page and select "Docs".

Check whether your books are placed or not.

2: Maybe your Mobi files are not purchased by yourself, which makes that you can copy to Kindle but your Kindle can't recognize it.

3: (If this mobi is purchased by your own account from Amazon)

Maybe Amazon has stopped selling this book any longer, and delete it from their library. If they abandoned one book, this book will disappear from your cloud and devices, because these books are linked to your account by amazon and you haven't back them up.

  1. A refer guide Kindle Transfer that may help you:
  • Restarting the kindle helped in my case. Would like to point out that I am using the new AWS format not the mobi one.
    – scipsycho
    Jul 16, 2021 at 18:13

I don't know why these books aren't showing up, but an alternative method you might try is using the Send to Kindle app from Amazon. There are versions for PC and Mac that you can download at www.amazon.com/sendtokindle.

  • Do you need an app? I thought kindle users actually had an email address, and you could just email an attachment to that address.
    – Auspex
    Nov 12, 2014 at 16:16
  • Yes, you can certainly use the email address, with no additional downloads requqired. I prefer the app personally because it integrates with Windows Explorer - when you right-click "Send to Kindle" is one of the options. It's just a personal preference.
    – Aravis
    Nov 14, 2014 at 15:32

Perhaps the books you copied had DRM, in which case the Kindle would not be able to read them.


You may want to check the settings on your pc, in particular the mobi files themselves. I'm not sure, but I've had "missing" files before. Try right clicking on the file and selecting "properties". From their, on the "General" tab, make sure at bottom (Attributes) the "Hidden" box isn't checked. Also, doing the same (right click / Properties) under "Security" tab make sure you have all "Full Control, Read, Write" etc in "Permissions for SYSTEM" checked to "Allow".


I have the same issue, and it can be resolved by choosing DOWNLOADED in the left - top corner under home button (it is ALL | DOWNLOADED will be there)


I've had this issue several times. Unfortunately I was not able to resolve this, though I've tried many different things:

  • Re-uploading the files again, moving across different folders
  • Rebooting kindle
  • Checking file permissions and collection views etc.

The only thing, that worked for me, unforturnately, was to do hard-reset, and then upload everything again... (of course firstly I've put copied everything to some backup folder on my PC).

One issue with doing that was that some books even lost progress tracking... and after further analysis it looked to me like there was some format change, e.g. progress files (I think those are files with *.mbs extension) had some hashes (some random set of characters) in their name, which I had to delete and then suddenly progress was visible, etc.

It got me thinking some time later, whether there was maybe some updates along the way, but I did not confirm that...

Anyway - blunt answer for me was: swear a alot, then calm down and backup everything, do hard-reset, upload it back and try to still love your kindle.

Edit: I just found a method that worked for me, move the "books" folder to a different location, restart the books app, maybe restart the kindle, eventually, all the old books will go away from the app's library. Then move the "books" folder back to where it belongs. I restarted the app and the kindle again and read a kindle store book for a while and when I went back to the library, all the mobis were there in the library.


I have had this exact same problem, if you have a paperwhite go to your home page click on 'All Items' then click 'Documents' I found my books in there

On the latest Paperwhite select Home then all then downloaded and they will show up in your library. Also type author's name or book title in search for quick access if you have lots of books.

Not the answer you're looking for? Browse other questions tagged or ask your own question.